summaryrefslogtreecommitdiffstats
path: root/Documentation/sphinx/kernellog.py
diff options
context:
space:
mode:
authorJonathan Corbet <corbet@lwn.net>2021-02-01 16:26:25 -0700
committerJonathan Corbet <corbet@lwn.net>2021-02-01 16:29:12 -0700
commitf546ff0c0c07969f2892db10f1fe029f841ddf10 (patch)
tree77d5c1d4f2f45f9d039232b91cc9d2867bba4f6f /Documentation/sphinx/kernellog.py
parent20ccc8dd38a391daba3a5a5dbd5443855100c517 (diff)
Move our minimum Sphinx version to 1.7
As promised, drop support for some ancient sphinx releases, along with a lot of the cruft that was required to make that support work. Signed-off-by: Jonathan Corbet <corbet@lwn.net>
Diffstat (limited to 'Documentation/sphinx/kernellog.py')
-rw-r--r--Documentation/sphinx/kernellog.py26
1 files changed, 8 insertions, 18 deletions
diff --git a/Documentation/sphinx/kernellog.py b/Documentation/sphinx/kernellog.py
index 8ac7d274f542..0bc00c138cad 100644
--- a/Documentation/sphinx/kernellog.py
+++ b/Documentation/sphinx/kernellog.py
@@ -4,29 +4,19 @@
# only goes back to 1.6. So here's a wrapper layer to keep around for
# as long as we support 1.4.
#
+# We don't support 1.4 anymore, but we'll keep the wrappers around until
+# we change all the code to not use them anymore :)
+#
import sphinx
+from sphinx.util import logging
-if sphinx.__version__[:3] >= '1.6':
- UseLogging = True
- from sphinx.util import logging
- logger = logging.getLogger('kerneldoc')
-else:
- UseLogging = False
+logger = logging.getLogger('kerneldoc')
def warn(app, message):
- if UseLogging:
- logger.warning(message)
- else:
- app.warn(message)
+ logger.warning(message)
def verbose(app, message):
- if UseLogging:
- logger.verbose(message)
- else:
- app.verbose(message)
+ logger.verbose(message)
def info(app, message):
- if UseLogging:
- logger.info(message)
- else:
- app.info(message)
+ logger.info(message)