summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRussell King <rmk@arm.linux.org.uk>2015-06-12 14:03:18 +0100
committerRussell King <rmk@arm.linux.org.uk>2015-06-12 16:23:01 +0100
commit84cda34f20299e644f1c19e74bd3b7d921483b1a (patch)
treec8d6338e0c3400977fb2faefcc8bae7ad91bb7df /Makefile.am
parenta1728ec7c6a657d6af12cd40d4ddf1ee19a8332b (diff)
Convert gst-plugins-base to stand-alone gst-plugins-xvbo package
We want to be a stand-alone package to support the xvboimagesink plugin, so we don't want to replicate most of gst-plugins-base code here. Delete mode of it, and rename ourselves appropriately. Signed-off-by: Russell King <rmk@arm.linux.org.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 3 insertions, 35 deletions
diff --git a/Makefile.am b/Makefile.am
index 0f188876..d14c9947 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,40 +1,21 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
-if BUILD_EXTERNAL
-SUBDIRS_EXT = ext
-else
-SUBDIRS_EXT =
-endif
-
SUBDIRS = \
- pkgconfig \
- gst-libs \
- gst sys $(SUBDIRS_EXT) \
- tools \
- tests \
- docs \
+ sys \
po \
common \
m4
DIST_SUBDIRS = \
- pkgconfig \
- docs \
- gst-libs \
- gst sys ext \
- tools \
- tests \
+ sys \
po \
common \
m4
-# include before EXTRA_DIST for win32 assignment
-include $(top_srcdir)/common/win32.mak
-
EXTRA_DIST = \
gst-plugins-base.spec depcomp \
AUTHORS COPYING COPYING.LIB NEWS README RELEASE REQUIREMENTS \
- ChangeLog gst-plugins-base.doap autogen.sh $(win32)
+ ChangeLog autogen.sh $(win32)
DISTCLEANFILES = _stdint.h
@@ -54,19 +35,6 @@ check-torture:
true
endif
-WIN32_COPY = \
- $(top_builddir)/gst-libs/gst/*/*-enumtypes.[ch] \
- $(top_builddir)/_stdint.h
-
-win32-update:
- for f in $(WIN32_COPY); do cp -v $$f win32/common; done; \
- for f in win32/common/*-enumtypes.c; do \
- echo "Indenting $$f"; \
- gst-indent $$f; gst-indent $$f; \
- done
- cp -v $(top_builddir)/win32/common/config.h-new \
- $(top_srcdir)/win32/common/config.h
-
include $(top_srcdir)/common/coverage/lcov.mak
check: check-exports