summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2009-05-15 16:12:37 -0700
committerDavid Schleef <ds@schleef.org>2009-05-15 16:18:59 -0700
commit0f1c5c1b68b69c9fda8c265dfbee6dc3e0900cc2 (patch)
tree2bf4ca9bdb55fc42df23e7607dcc84d8888ed417 /configure.ac
parent4ec34e83d5a6664c85a5f7bc7a48a65746b2b688 (diff)
schro: Move schro plugin from Schroedinger
Previous history is in Schroedinger. Depends on, and is an example of using, GstBaseVideo* base classes. Code was reindented, and an #ifdef HAVE_ENCODER removed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 600d2fbf..4fdb097c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -566,6 +566,12 @@ AG_GST_CHECK_FEATURE(PANGO, [Pango font rendering], pango, [
AG_GST_PKG_CHECK_MODULES(PANGO, pango pangoft2)
])
+dnl *** schroedinger ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SCHRO, true)
+AG_GST_CHECK_FEATURE(SCHRO, [Schroedinger video codec], schro, [
+ AG_GST_PKG_CHECK_MODULES(SCHRO, schroedinger-1.0 >= 1.0.7)
+])
+
dnl *** theora ***
translit(dnm, m, l) AM_CONDITIONAL(USE_THEORA, true)
AG_GST_CHECK_FEATURE(THEORA, [Xiph Theora video codec], theora, [
@@ -619,6 +625,7 @@ AM_CONDITIONAL(USE_GIO, false)
AM_CONDITIONAL(USE_LIBVISUAL, false)
AM_CONDITIONAL(USE_OGG, false)
AM_CONDITIONAL(USE_PANGO, false)
+AM_CONDITIONAL(USE_SCHRO, false)
AM_CONDITIONAL(USE_THEORA, false)
AM_CONDITIONAL(USE_VORBIS, false)
@@ -735,6 +742,7 @@ ext/gio/Makefile
ext/libvisual/Makefile
ext/ogg/Makefile
ext/pango/Makefile
+ext/schroedinger/Makefile
ext/theora/Makefile
ext/vorbis/Makefile
gst-libs/Makefile