summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Matthew <jonathan@d14n.org>2009-06-19 11:27:40 +1000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-06-19 22:21:03 +0100
commit9daee1f4a9195ab040db1a2180e6eece1ee2997e (patch)
tree6b206e362662db7ea69043c365f1924aea9c75a7 /configure.ac
parentb80b350840e6e04efc70067a2a3483dce9690274 (diff)
cdparanoia: expose cache size setting
This setting was added in cdparanoia 10.2. The default value is good for audio extraction, but lower values (previous versions of cdparanoia used 150) are better for realtime playback. Fixes #586331.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ebf698e..260aea58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -480,6 +480,14 @@ AG_GST_CHECK_FEATURE(CDPARANOIA, [CDParanoia], cdparanoia, [
AC_DEFINE_UNQUOTED(CDPARANOIA_HEADERS_IN_DIR, ,
defined if cdda headers are in a cdda/ directory)
fi
+ if test "x$FOUND_CDPARANOIA" = "xyes";
+ then
+ AC_CHECK_LIB(cdda_paranoia,
+ paranoia_cachemodel_size,
+ : ,
+ HAVE_CDPARANOIA=no)
+ fi
+
AC_SUBST(CDPARANOIA_LIBS)
])
dnl FIXME : add second check somehow if that is necessary