summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-09-02 15:07:09 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-09-02 15:07:09 +0000
commitafffd2d620810a1de46edd11d030c58536da66fc (patch)
tree49d477154904581c5a784e0a7de60e14d23beeeb /configure.ac
parent2fcee6f44982ea947a356bdb7d2258eddb5e1af5 (diff)
configure.ac: Disable subparse when xml is disabled. It woundn't work anyway. Fixes test runs.
Original commit message from CVS: * configure.ac: Disable subparse when xml is disabled. It woundn't work anyway. Fixes test runs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2bd81f10..11e7f96f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,6 +304,13 @@ AG_GST_CHECK_PLUGIN(videorate)
AG_GST_CHECK_PLUGIN(videoscale)
AG_GST_CHECK_PLUGIN(volume)
+dnl check for gstreamer core features (subsystems)
+GST_CONFIGPATH=`$PKG_CONFIG --variable=includedir gstreamer-0.10`"/gst/gstconfig.h"
+AG_GST_PARSE_SUBSYSTEM_DISABLES($GST_CONFIGPATH)
+if test $GST_DISABLE_XML = "1"; then
+ AG_GST_DISABLE_PLUGIN(subparse)
+fi
+
dnl disable plug-ins that require libxml2's HTML support if it is not available
if test "x$HAVE_LIBXML_HTML" != "xyes"; then
AG_GST_DISABLE_PLUGIN(subparse)