summaryrefslogtreecommitdiff
path: root/ext/vorbis/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/vorbis/Makefile.am')
-rw-r--r--ext/vorbis/Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/ext/vorbis/Makefile.am b/ext/vorbis/Makefile.am
index 078eb98e..fc285a8d 100644
--- a/ext/vorbis/Makefile.am
+++ b/ext/vorbis/Makefile.am
@@ -1,13 +1,17 @@
-plugin_LTLIBRARIES = libgstvorbis.la
+plugin_LTLIBRARIES =
+
+if USE_VORBIS
+plugin_LTLIBRARIES += libgstvorbis.la
libgstvorbis_la_SOURCES = gstvorbis.c \
gstvorbisdec.c \
+ gstvorbisdeclib.c \
gstvorbisenc.c \
gstvorbisparse.c \
gstvorbistag.c \
gstvorbiscommon.c
-libgstvorbis_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(VORBIS_CFLAGS)
+libgstvorbis_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(VORBIS_CFLAGS)
## AM_PATH_VORBIS also sets VORBISENC_LIBS
libgstvorbis_la_LIBADD = \
$(top_builddir)/gst-libs/gst/tag/libgsttag-@GST_MAJORMINOR@.la \
@@ -16,9 +20,26 @@ libgstvorbis_la_LIBADD = \
$(VORBIS_LIBS) $(VORBISENC_LIBS)
libgstvorbis_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstvorbis_la_LIBTOOLFLAGS = --tag=disable-static
+endif
+
+if USE_IVORBIS
+plugin_LTLIBRARIES += libgstivorbisdec.la
+
+libgstivorbisdec_la_SOURCES = gstivorbisdec.c \
+ gstvorbisdec.c gstvorbisdeclib.c gstvorbiscommon.c
+libgstivorbisdec_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
+ -DTREMOR $(IVORBIS_CFLAGS)
+libgstivorbisdec_la_LIBADD = \
+ $(top_builddir)/gst-libs/gst/tag/libgsttag-@GST_MAJORMINOR@.la \
+ $(top_builddir)/gst-libs/gst/audio/libgstaudio-@GST_MAJORMINOR@.la \
+ $(GST_LIBS) $(IVORBIS_LIBS)
+libgstivorbisdec_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstivorbisdec_la_LIBTOOLFLAGS = --tag=disable-static
+endif
noinst_HEADERS = gstvorbisenc.h \
gstvorbisdec.h \
+ gstvorbisdeclib.h \
gstvorbisparse.h \
gstvorbistag.h \
gstvorbiscommon.h