summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRussell King <rmk@arm.linux.org.uk>2013-06-22 20:47:14 +0100
committerRussell King <rmk@arm.linux.org.uk>2013-06-23 12:01:50 +0100
commit77278b1df19e482dc26c2a9636fbf97dd882a70d (patch)
treeaa5c08c2fee24802ba07f1025abfa815f8b20568 /Makefile.am
parentf1383479463443d22cf9f730adf40679e59ea2fc (diff)
Make libbmm more efficient
libbmm calls into the kernel a lot to perform various functions such as translating between virtual and physical addresses, finding out the buffer size, and so forth. Much of this can be done in userspace, because we have that information at the point where the buffer is allocated. Rather than having to keep fetching it from the kernel, store it in our own local bmm_buffer structure, and store this in a pair of rb trees - one indexed by physical address and the other by virtual address. This allows us to efficiently look up the bmm_buffer structure by either address, and retrieve the other buffer attribute(s). Reference: http://web.eecs.utk.edu/~plank/plank/rbtree/rbtree.html
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c135cb7..02ab833 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@ libbmm_la_LTLIBRARIES = libbmm.la
libbmm_ladir = $(libdir)
libbmm_la_LDFLAGS = -no-undefined -export-symbols-regex "bmm_*" \
-version-info @ABI_VERSION@:@ABI_REVISION@:@ABI_AGE@
-libbmm_la_SOURCES = bmm_lib.c bmm_lib_priv.h
+libbmm_la_SOURCES = bmm_lib.c bmm_lib_priv.h rb.c rb.h
libbmm_laincludedir = $(includedir)
libbmm_lainclude_HEADERS = bmm_lib.h