summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRussell King <rmk@arm.linux.org.uk>2013-06-23 11:56:13 +0100
committerRussell King <rmk@arm.linux.org.uk>2013-06-23 12:06:30 +0100
commitab1e6647aa7e4a2f2da5196e52ac86884ffde284 (patch)
tree4960b2d8b8cb119a767838fec3d8af0dfa05cad6 /Makefile.am
parent2f9be2b33130e780a72826598c5bb0a927bc867f (diff)
Turn on compiler warnings and fix them
Fix the "warning: function declaration isn't a prototype" warnings in the bmm_lib code, printf formats in the test code, and make test functions static.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 02ab833..fe67d9c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-AM_CFLAGS = $(WARN_CFLAGS)
+AM_CFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes $(WARN_CFLAGS)
libbmm_la_LTLIBRARIES = libbmm.la
libbmm_ladir = $(libdir)