summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRussell King <rmk+cubox@arm.linux.org.uk>2013-12-08 21:29:56 +0000
committerRussell King <rmk@arm.linux.org.uk>2013-12-08 22:02:42 +0000
commit6f2e8ec4c736fbffe3d0e0f1ec07f453910441a1 (patch)
tree3adfc685d5addab0a3d7a609a0d620b0046a6bee /debian
parentdcad449e26e81b71e4a498dc5bfaf014a5566acd (diff)
BMMv2: dma_buf based BMMHEADv2.0.0master
This is a complete redesign and rewrite of libbmm. This implementation is based upon dma_bufs - where a dma_buf is a kernel-side buffer which can be passed to and from other subsystems. libbmm becomes a provider of dma_bufs - it permits userspace to allocate such things. When a dma_buf is allocated, userspace is handed a file descriptor which is unique to this buffer. This file descriptor can then be passed into other subsystems, which can then request access to this buffer. The file descriptor supports very few operations - it can be mmap()d to provide userspace access to the buffer, and it can be closed when it is no longer required. Internally in the kernel, dma_bufs are reference counted, so the dma_buf will only be freed when the last user gives up its reference.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control17
-rw-r--r--debian/libbmm-dev.install1
-rw-r--r--debian/libbmm2.install (renamed from debian/libbmm1.install)0
-rwxr-xr-xdebian/rules3
5 files changed, 16 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index ad0235c..bd83008 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libbmm (2.0.0) precise; urgency=low
+
+ * Major update, now using purely dma_buf as a management system for
+ buffers.
+
+ -- Russell King <rmk@arm.linux.org.uk> Sat, 7 Dec 2013 15:01:15 +0000
+
marvell-libbmm (1.1.3) precise; urgency=low
* Fix dma_import() handling of offset buffers
diff --git a/debian/control b/debian/control
index de0a4bf..f375bbd 100644
--- a/debian/control
+++ b/debian/control
@@ -1,11 +1,10 @@
-Source: marvell-libbmm
+Source: libbmm
Priority: extra
-Maintainer: Michael Casadevall <mcasadevall@ubuntu.com>
+Maintainer: Russell King <rmk@arm.linux.org.uk>
XSBC-Original-Maintainer: Li Li <lea.li@marvell.com>
Build-Depends: debhelper (>= 7)
Standards-Version: 3.9.1
Section: libs
-Vcs-Bzr: https://code.launchpad.net/~adana-team/adana/marvell-libbmm
Package: libbmm-common
Section: libs
@@ -16,25 +15,23 @@ Description: Block/buffer memory management
Package: libbmm-dev
Section: libdevel
Architecture: armel armhf
-Depends: libbmm1 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
+Depends: libbmm2 (= ${binary:Version}), ${misc:Depends}
Description: Block/buffer memory management
Header files, static library and unit test case for BMM
-Package: libbmm1
+Package: libbmm2
Section: libs
Architecture: armel armhf
Depends: libbmm-common, ${shlibs:Depends}, ${misc:Depends}
Description: Block/buffer memory management
Allocate, manage and share large block of physical continuous memory
-Package: libbmm1-dbg
+Package: libbmm2-dbg
Section: debug
Priority: extra
Architecture: linux-any
-Depends:
- libbmm1 (= ${binary:Version}),
- ${misc:Depends},
+Depends: libbmm2 (= ${binary:Version}), ${misc:Depends},
Multi-Arch: same
Description: Block/buffer memory management
.
- This package provides debugging symbols for the libbmm0u package.
+ This package provides debugging symbols for the libbmm2 package.
diff --git a/debian/libbmm-dev.install b/debian/libbmm-dev.install
index 57bfa73..e5091ec 100644
--- a/debian/libbmm-dev.install
+++ b/debian/libbmm-dev.install
@@ -2,4 +2,3 @@ debian/tmp/usr/include/*.h
debian/tmp/usr/lib/*.a
debian/tmp/usr/lib/*.so
debian/tmp/usr/lib/pkgconfig/*.pc
-debian/tmp/usr/bin/bmm_test
diff --git a/debian/libbmm1.install b/debian/libbmm2.install
index 79bbe2f..79bbe2f 100644
--- a/debian/libbmm1.install
+++ b/debian/libbmm2.install
diff --git a/debian/rules b/debian/rules
index ced92e5..b0098b2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,7 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+LIBBMM=libbmm2
override_dh_auto_install:
dh_auto_install --destdir=debian/tmp
@@ -17,7 +18,7 @@ override_dh_install:
dh_install --fail-missing
override_dh_strip:
- dh_strip -plibbmm1 --dbg-package=libbmm1-dbg
+ dh_strip -p$(LIBBMM) --dbg-package=$(LIBBMM)-dbg
dh_strip -s --remaining-packages
%: