summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell King <rmk@arm.linux.org.uk>2013-06-23 09:51:20 +0100
committerRussell King <rmk@arm.linux.org.uk>2013-06-23 09:54:19 +0100
commit791f2728d4030ec8f453463fba95647ce19767b9 (patch)
tree999c773edd2aed5f3d7d467a6ec9e75e3bd4d7a1 /configure.ac
parentd2ba876f81bd13679a842f94a5111109ffee78d6 (diff)
Convert to use bmm_malloc_aligned_phys() API
BMM internally allocates memory by physical address, and then maps it to a virtual address. Rather than using an API which returns the virtual address which then has to be re-translated back to a physical address, use an API which gets us all the information we need in one go. This gets rid of the bmm_get_paddr() step when allocating memory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d93af29..5b8ab19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@ AC_USE_SYSTEM_EXTENSIONS
LT_PREREQ([2.2])
LT_INIT
-PKG_CHECK_MODULES(LIBBMM, libbmm)
+PKG_CHECK_MODULES(LIBBMM, libbmm >= 1.1.0)
AC_SUBST(LIBBMM_CFLAGS)
AC_SUBST(LIBBMM_LIBS)