summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c417c46..22ed76e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -296,7 +296,9 @@ PKG_CHECK_MODULES(PRESENT, [presentproto >= 1.0], , PRESENT=no)
if test x$PRESENT != xno; then
save_CFLAGS=$CFLAGS
CFLAGS="$XORG_CFLAGS $PRESENT_CFLAGS"
- AC_CHECK_HEADERS([present.h], PRESENT=yes, PRESENT=no, [#include <dixstruct.h>])
+ AC_CHECK_HEADERS([present.h], PRESENT=yes, PRESENT=no,
+ [#include <xorg-server.h>]
+ [#include <dixstruct.h>])
CFLAGS=$save_CFLAGS
fi
AC_MSG_CHECKING([whether to include PRESENT support])