summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYouling Tang <tangyouling@loongson.cn>2022-09-28 10:28:23 +0800
committerSimon Horman <horms@kernel.org>2022-10-10 13:34:54 +0200
commit1c8bf2dc0127b06f97a7973488c7f8cf9a5f7c19 (patch)
treeba9628df718ee3459e066274c59aa0a032790c42 /configure.ac
parentdceb1d8926e609ccf8f00e92001226888529283b (diff)
LoongArch: Add kexec/kdump support
Add the 64-bit processing support of the LoongArch architecture. For the time being, the quick restart function(kexec) is supported. That is, the "kexec -l" and "kexec -e" commands can be used normally. At the same time, the crash dump function also supports, "kexec -p" operation can be successfully performed, and the vmcore file can be generated. I tested this on LoongArch 3A5000 machine and works as expected, kexec: $ sudo kexec -l /boot/vmlinux --reuse-cmdline $ sudo kexec -e kdump: $ sudo kexec -p /boot/vmlinux-kdump --reuse-cmdline --append="nr_cpus=1" # echo c > /proc/sysrq_trigger Signed-off-by: Youling Tang <tangyouling@loongson.cn> Signed-off-by: Simon Horman <horms@kernel.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d73b765..d081c82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,9 @@ case $target_cpu in
hppa*)
ARCH="hppa"
;;
+ loongarch*)
+ ARCH="loongarch"
+ ;;
* )
AC_MSG_ERROR([unsupported architecture $target_cpu])
;;