summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Uvarov <muvarov@gmail.com>2010-09-07 19:10:33 +0400
committerSimon Horman <horms@verge.net.au>2010-09-09 09:43:11 +0900
commit66969c5f3b039df6f5b96e4115f83e502834c01e (patch)
tree5cc87b8298f2c01a531c7b0fceb400f0eaf1ccef /configure.ac
parentdbe1163152ef6fca2a1bd22e11e219f58fd40c08 (diff)
Revert "Revert "powerpc new toolchains fix (crt.S)""
Revert the revert patch specially made to remove 45e8f29639d9f97b74389e5bd28c7a5cccbf3e2a commit from git tree. This reverts commit c42b92cd1f3c6c2e812bd1fcc4203672f3b6d461. Revert "powerpc new toolchains fix (crt.S)" This reverts commit 45e8f29639d9f97b74389e5bd28c7a5cccbf3e2a. purgatory/arch/ppc/crt.S and purgatory/arch/ppc/misc.S are the same files. Signed-off-by: Maxim Uvarov <muvarov@gmail.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2960c25..7f6acc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,15 @@ if test "$with_xen" = yes ; then
AC_MSG_NOTICE([Xen support disabled])))
fi
+dnl new toolchains
+if test "$ARCH" = ppc; then
+AC_ARG_WITH([oldtoolchain],
+ AC_HELP_STRING([--with-oldtoolchain],[compile without crt.S
+ required for new toolchains]),
+ AC_DEFINE(PPC_OLDTOOLCHAIN, 1,
+ [Define to compile with old toolchains]))
+fi
+
dnl ---Sanity checks
if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]); fi
if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]); fi