summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSuzuki K. Poulose <suzuki@in.ibm.com>2011-10-03 15:48:12 +0530
committerSimon Horman <horms@verge.net.au>2011-10-21 16:46:21 +0900
commit90da2c3735b9ee4ddc80257c6036816bd570dcc8 (patch)
tree5a8e668d4e9e2b0d630ea948426f7a017a2d1f5e /configure.ac
parentec4d31441ed4ea6ab320b63cc1472eda46e70ca2 (diff)
kexec: powerpc: crash_dump: No backup region for PPC BookE
Disable backup regions for BookE in case of a CRASH Dump, as they can be run from anywhere. The patch introduces --with-booke option to support the BookE. With the patch, we get : ## On a 256M machine: # busybox cat /proc/cmdline init=/bin/init console=ttyS0,16550 crashkernel=128M@100M # kexec -p root/vmlinux usable memory rgns size:1 base:6400000 size:8000000 CRASH MEMORY RANGES 0000000000000000-0000000006400000 000000000e400000-0000000010000000 Command line after adding elfcorehdr: elfcorehdr=112380K Command line after adding elfcorehdr: elfcorehdr=112380K savemaxmem=256M Signed-off-by: Suzuki K. Poulose<suzuki@in.ibm.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0d09bba..7dd6028 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,11 @@ AC_ARG_WITH([lzma], AC_HELP_STRING([--without-lzma],[disable lzma support]),
AC_ARG_WITH([xen], AC_HELP_STRING([--without-xen],
[disable extended xen support]), [ with_xen="$withval"], [ with_xen=yes ] )
+AC_ARG_WITH([booke],
+ AC_HELP_STRING([--with-booke],[build for booke]),
+ AC_DEFINE(CONFIG_BOOKE,1,
+ [Define to build for BookE]))
+
dnl ---Programs
dnl To specify a different compiler, just 'export CC=/path/to/compiler'