summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormichael <michael@82007160-df01-0410-b94d-b575c5fd34c7>2013-10-23 18:08:17 +0000
committermichael <michael@82007160-df01-0410-b94d-b575c5fd34c7>2013-10-23 18:08:17 +0000
commit07ba5303757ea42fdf7dee25a57c4a89b6427df5 (patch)
tree15c96b0683f00f4ff1410b5f99e3ab82a80bebbb /configure.ac
parenta20a47cc26c51a2dabbb11e0f6274c645f29f6c3 (diff)
- Initial build system related modernizations
- Add -fstack-protector to CFLAGS if available - Move openssl check to m4/ax_check_openssl.m4 git-svn-id: svn://svn.ircd-hybrid.org/svnroot/ircd-hybrid/branches/8.1.x@2485 82007160-df01-0410-b94d-b575c5fd34c7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac88
1 files changed, 4 insertions, 84 deletions
diff --git a/configure.ac b/configure.ac
index ac2c683..02b1a04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,7 @@ AC_PREREQ(2.69)
AC_INIT([ircd-hybrid], [8.1.7], [bugs@ircd-hybrid.org])
AM_INIT_AUTOMAKE(1.13.1 subdir-objects)
AM_MAINTAINER_MODE
+AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADER(config.h)
AC_CONFIG_SRCDIR(src/ircd.c)
@@ -25,6 +26,8 @@ LTDL_INIT([recursive convenience])
LIBTOOL="$LIBTOOL --silent"
# Checks for libraries.
+GCC_STACK_PROTECT_CC
+
AX_CHECK_LIB_IPV4
AX_CHECK_LIB_IPV6
@@ -54,90 +57,7 @@ AC_ARG_ENABLE(libgeoip,
[AC_SEARCH_LIBS(GeoIP_id_by_ipnum_v6_gl, GeoIP,
[AC_DEFINE(HAVE_LIBGEOIP, 1, [Define to 1 if libGeoIP (-lGeoIP) is available.])])])], [])
-dnl Openssl checks
-AC_ARG_ENABLE(openssl,
-[ --enable-openssl[=DIR] Enable OpenSSL support (DIR optional).
- --disable-openssl Disable OpenSSL support. ],
-[ cf_enable_openssl=$enableval ],
-[ cf_enable_openssl="auto" ])
-AC_MSG_CHECKING([for OpenSSL])
-if test "$cf_enable_openssl" != "no"; then
- cf_openssl_basedir=""
- if test "$cf_enable_openssl" != "auto" &&
- test "$cf_enable_openssl" != "yes"; then
- dnl Support for --enable-openssl=/some/place
- cf_openssl_basedir="${cf_enable_openssl}"
- else
- dnl Do the auto-probe here. Check some common directory paths.
- for dirs in /usr/local/ssl /usr/pkg /usr/local /usr/lib /usr/lib/ssl\
- /opt /opt/openssl /usr/local/openssl; do
- if test -f "${dirs}/include/openssl/opensslv.h"; then
- cf_openssl_basedir="${dirs}"
- break
- fi
- done
- unset dirs
- fi
-
- dnl Now check cf_openssl_found to see if we found anything.
- if test ! -z "$cf_openssl_basedir"; then
- if test -f "${cf_openssl_basedir}/include/openssl/opensslv.h"; then
- CPPFLAGS="-I${cf_openssl_basedir}/include $CPPFLAGS"
- LDFLAGS="-L${cf_openssl_basedir}/lib $LDFLAGS"
- else
- dnl OpenSSL wasn't found in the directory specified. Naughty
- dnl administrator...
- cf_openssl_basedir=""
- fi
- else
- dnl Check for stock FreeBSD 4.x and 5.x systems, since their files
- dnl are in /usr/include and /usr/lib. In this case, we don't want to
- dnl change INCLUDES or LIBS, but still want to enable OpenSSL.
- dnl We can't do this check above, because some people want two versions
- dnl of OpenSSL installed (stock FreeBSD 4.x/5.x and /usr/local/ssl)
- dnl and they want /usr/local/ssl to have preference.
- if test -f "/usr/include/openssl/opensslv.h"; then
- cf_openssl_basedir="/usr"
- fi
- fi
-
- dnl If we have a basedir defined, then everything is okay. Otherwise,
- dnl we have a problem.
- if test ! -z "$cf_openssl_basedir"; then
- AC_MSG_RESULT([$cf_openssl_basedir])
- cf_enable_openssl="yes"
- else
- AC_MSG_RESULT([not found. Please check your path.])
- cf_enable_openssl="no"
- fi
- unset cf_openssl_basedir
-else
- dnl If --disable-openssl was specified
- AC_MSG_RESULT([disabled])
-fi
-
-AS_IF([test "$cf_enable_openssl" != "no"],
- [AC_MSG_CHECKING(for OpenSSL 0.9.8 or above)
- AC_RUN_IFELSE([
- AC_LANG_PROGRAM([
- #include <openssl/opensslv.h>
- #include <stdlib.h>],
- [[ exit(!(OPENSSL_VERSION_NUMBER >= 0x00908000)); ]])],
- [cf_openssl_version_ok=yes],
- [cf_openssl_version_ok=no],
- [cf_openssl_version_ok=no])
-
- AS_IF([test "$cf_openssl_version_ok" = "yes"],
- [AC_MSG_RESULT(found)
-
- AC_CHECK_LIB(crypto, RSA_free)
- AS_IF([test "$ac_cv_lib_crypto_RSA_free" = "yes"],
- [AC_CHECK_LIB(ssl, SSL_connect)])
- ],[AC_MSG_RESULT(no - OpenSSL support disabled)
- cf_enable_openssl="no"])])
-
-AM_CONDITIONAL(ENABLE_SSL, [test "$ac_cv_lib_ssl_SSL_connect" = yes])
-
+AX_CHECK_OPENSSL
AC_ARG_ENABLE(assert, AS_HELP_STRING([--enable-assert],
[Enable assert() statements]),