summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormichael <michael@82007160-df01-0410-b94d-b575c5fd34c7>2013-04-24 19:43:22 +0000
committermichael <michael@82007160-df01-0410-b94d-b575c5fd34c7>2013-04-24 19:43:22 +0000
commitb552f5f5b2d35b7a1b331c4a890f7f754193a92c (patch)
tree6a300cfd5df91941738c916654ded8a41575de28 /configure.ac
parent2024c475d81bd08593b25694a5b9edaf056d856f (diff)
- Added configure test for libGeoIP for later usage
git-svn-id: svn://svn.ircd-hybrid.org/svnroot/ircd-hybrid/trunk@1856 82007160-df01-0410-b94d-b575c5fd34c7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8efde04..b163923 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,12 @@ AC_ARG_ENABLE(libpcre,
[AC_SEARCH_LIBS(pcre_study, pcre,
[AC_DEFINE(HAVE_LIBPCRE, 1, [Define to 1 if libpcre (-lpcre) is available.])])])], [])
+AC_ARG_ENABLE(libGeoIP,
+ [AS_HELP_STRING([--disable-libgeoip],[Disable GeoIP support])], [],
+ [AC_CHECK_HEADER(GeoIP.h,
+ [AC_SEARCH_LIBS(GeoIP_id_by_ipnum_v6_gl, GeoIP,
+ [AC_DEFINE(HAVE_LIBGEOIP, 1, [Define to 1 if libGeoIP (-lGeoIP) is available.])])])], [])
+
dnl Openssl checks
AC_ARG_ENABLE(openssl,
[ --enable-openssl[=DIR] Enable OpenSSL support (DIR optional).